Перейти к содержимому


Появилась ошибка...


Сообщений в теме: 3

#1 AEROBATICS

    Пользователь

  • Пользователи
  • PipPip
  • 14 сообщений

Отправлено 09 Ноябрь 2017 - 06:07

Решил создать тему, в которой можно указывать свои вопросы по появлению различных ошибок системы тестирования.

Начну со своей проблемы. Переставил Win10 Pro. Восстановил БД из бэкапа. При нажатии кнопки "Создать новый тест" ввожу название нового теста и нажимаю OK, тут появляется сообщение об ошибке и при нажатии на кнопку OK приложение закрывается (вылетает). :wacko: :blink:
В итоге, после перезапуска приложения в списке тестов они появляются, но при попытке открыть всё то же окно и вылет....Смотрел логи сервера в папке, но там ничего конкретного нет.
Журнал событий Win помог:
- &--#60;Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"&--#62;
- &--#60;System&--#62;
  &--#60;Provider Name="PostgreSQL" /&--#62;
  &--#60;EventID Qualifiers="0"&--#62;0&--#60;/EventID&--#62;
  &--#60;Level&--#62;4&--#60;/Level&--#62;
  &--#60;Task&--#62;0&--#60;/Task&--#62;
  &--#60;Keywords&--#62;0x80000000000000&--#60;/Keywords&--#62;
  &--#60;TimeCreated SystemTime="2017-11-09T03:22:53.027662000Z" /&--#62;
  &--#60;EventRecordID&--#62;27859&--#60;/EventRecordID&--#62;
  &--#60;Channel&--#62;Application&--#60;/Channel&--#62;
  &--#60;Computer&--#62;*********-3IP89RL&--#60;/Computer&--#62;
  &--#60;Security /&--#62;
  &--#60;/System&--#62;
- &--#60;EventData&--#62;
  &--#60;Data&--#62;LOG: unexpected EOF on client connection&--#60;/Data&--#62;
  &--#60;/EventData&--#62;
  &--#60;/Event&--#62;

P.S. Удалил ПО и все хвосты. ВСЕ.
Поставил с нуля (без бэкапа(стерильное)), тоже самое, хоть с лицензией, хоть без.
log:
[Thu Nov 09 06:36:48.295356 2017] [mpm_winnt:notice] [pid 7544:tid 920] AH00455: Apache/2.4.20 (Win32) mod_bikeshed/0.1.1 configured -- resuming normal operations
[Thu Nov 09 06:36:48.295356 2017] [mpm_winnt:notice] [pid 7544:tid 920] AH00456: Server built: Apr  4 2016 12:15:57
[Thu Nov 09 06:36:48.295356 2017] [core:notice] [pid 7544:tid 920] AH00094: Command line: 'C:\\Program Files (x86)\\INDIGO\\server\\bin\\IndigoServer.exe -d C:/Program Files (x86)/INDIGO/server'
[Thu Nov 09 06:36:48.310979 2017] [mpm_winnt:notice] [pid 7544:tid 920] AH00418: Parent: Created child process 6420
Apache server shutdown initiated...
pm_winnt:notice] [pid 6420:tid 928] AH00354: Child: Starting 350 worker threads.
[Thu Nov 09 06:39:41.439747 2017] [mpm_winnt:notice] [pid 7544:tid 920] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Thu Nov 09 06:39:43.471104 2017] [mpm_winnt:notice] [pid 6420:tid 928] AH00364: Child: All worker threads have exited.
[Thu Nov 09 06:39:43.486731 2017] [mpm_winnt:notice] [pid 7544:tid 920] AH00430: Parent: Child process 6420 exited successfully.
[Thu Nov 09 06:40:40.065555 2017] [mpm_winnt:notice] [pid 6180:tid 928] AH00455: Apache/2.4.20 (Win32) mod_bikeshed/0.1.1 configured -- resuming normal operations
[Thu Nov 09 06:40:40.065555 2017] [mpm_winnt:notice] [pid 6180:tid 928] AH00456: Server built: Apr  4 2016 12:15:57
[Thu Nov 09 06:40:40.065555 2017] [core:notice] [pid 6180:tid 928] AH00094: Command line: 'C:\\Program Files (x86)\\INDIGO\\server\\bin\\IndigoServer.exe -d C:/Program Files (x86)/INDIGO/server'
[Thu Nov 09 06:40:40.065555 2017] [mpm_winnt:notice] [pid 6180:tid 928] AH00418: Parent: Created child process 4652
[Thu Nov 09 06:40:40.409334 2017] [mpm_winnt:notice] [pid 4652:tid 1020] AH00354: Child: Starting 350 worker threads.

Прикрепленные изображения

  • Прикрепленное изображение: Screenshot_5.png
  • Прикрепленное изображение: Screenshot_6.png
  • Прикрепленное изображение: Screenshot_7.png


#2 Administrator

    Менеджер проекта

  • Администраторы
  • 1 157 сообщений

Отправлено 09 Ноябрь 2017 - 12:46

:o Лично я вообще ничего не понял. То что Вы привели это каша. Ошибка в журнале win абсолютно штатная, это значит клиент отрубился от СУБД без предупреждения, в этом нет ничего страшного. Логи web-сервера Apache тут тоже не причем, это не взаимосвязанные компоненты, да в этих логах нет никаких ошибок. Сама программа абсолютно портабельна. Ее можно переносить с компа на комп без необходимости переустановки. Главное условие это перенос на холодную в выключенном виде (выполнение INDIGO\server\uninstall.bat перед переносом) и последующий запуск после переноса (INDIGO\server\install.bat), а также необходимо отсутствие кириллических символов в пути к папке с программой. Больше никаких требований нет. В случае восстановления бекапа можно ставить систему тестирования заново, отключать ее работу (INDIGO\server\uninstall.bat) заменять папку с базой (INDIGO\database) и запускать (INDIGO\server\install.bat), т.е. принципы те же.

Цитата

P.S. Удалил ПО и все хвосты. ВСЕ.
Поставил с нуля (без бэкапа(стерильное)), тоже самое, хоть с лицензией, хоть без.

Т.е. Вы просто установили программу заново и все равно ничего не работает? Бекап тогда тут был не причем и хвостов у программы нет. Если на чистой установке не работает, то это уникальный случай! Такого ещё не было. Да и последнюю версию 2.0 RC8 уже можно считать хорошо обкатанной (за 3 месяца ее установили несколько тысяч раз). Сможем посмотреть, если дадите доступ через TeamViewer (для оперативности skype:execoma или whatsapp +7 988 733 22 22). Скорее всего здесь воздействие какого-то внешнего софта в системе.

#3 AEROBATICS

    Пользователь

  • Пользователи
  • PipPip
  • 14 сообщений

Отправлено 09 Ноябрь 2017 - 18:57

Что теоретически может повлиять на приложение и его работу? Вычистил все места и даже реестр вручную. Потом прошёлся ПО RegOrganizer. Соответственно ничего нигде не осталось. Установку производил с правами администратора. Возможно дело в каком-то другом компоненте, который не входит в состав инсталляционного пакета, а требуется от ОС по дефолту? SQL-компоненты или др.?
Проблемы начались после перестановки ОС.

Сомневаюсь во влиянии внешнего софта. Переустановил на ноутбуке два варианта ОС Win10 и на чистой системе при чистой установке тот же результат.
Т.е. ОС была совершенно чистая.
В попытках разобраться установил Java и flash player.
Может быть какой-нибудь NET framework?

#4 Administrator

    Менеджер проекта

  • Администраторы
  • 1 157 сообщений

Отправлено 10 Ноябрь 2017 - 10:57

Просмотр сообщенияAEROBATICS (09 Ноябрь 2017 - 18:57) писал:

Сомневаюсь во влиянии внешнего софта. Переустановил на ноутбуке два варианта ОС Win10 и на чистой системе при чистой установке тот же результат.

Удивительно, потому что ни у кого больше нет таких проблем. Надо смотреть.
Что за система? Откуда она скачивалась, с торрентов? Есть ссылка на тот экземпляр?




Ответить



  


Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 анонимных