Перейти к содержимому


[Отклонено] Ошибка при выводе результатов тестирования


Сообщений в теме: 2

#1 SMARTtech.ru

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 37 сообщений

Отправлено 26 Май 2014 - 09:05

Привет, недавно получили ошибку в результатах о прохождении теста:

100 - <ошибка: нет принадлежности к делениям шкалы>

Подскажите, пожалуйста, как исправить тестирование, чтобы такая ошибка больше не появлялась?.

Прикрепленное изображение: Untitled.pngПрикрепленное изображение: Untitled1.pngПрикрепленное изображение: Untitled2.png

#2 Administrator

    Менеджер проекта

  • Администраторы
  • 1 421 сообщений

Отправлено 26 Май 2014 - 10:53

Это ошибка составления теста, а не ошибка программы. У Вас значение 100 не попадает ни в одно деление, т.к. где 100 стоит круглая скобка, а не квадратная. Тоже самое у Вас будет с 84 или 94, или с промежутками [84;85) и [94;95) - если например будет значение 84,5 или 94,5 - а это может быть запросто, т.к. у Вас там используется деление в функции шкалы. Это очень подробно с примерами расписано в документации https://indigotech.ru/manual пункт 2.2.2 (подпункт Ошибки вычисления результатов) - очень желательно прочитать всем, кто пользуется INDIGO.

Вам нужно задать Ваши деления так:

[0;85) - 0 ≤ x < 85
[85;95) - 85 ≤ x < 95
[95;100] - 95 ≤ x ≤100

Тогда будет покрываться весь диапазон от 0 до 100.

#3 SMARTtech.ru

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 37 сообщений

Отправлено 26 Май 2014 - 11:42

понял, спасибо!



Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 анонимных